Sign In | Register |
0

IAR Version for SDK.ewp

Issue Report - Created by James on 5/8/2017 1:33:38 PM
Actions

James

Posted
3 years ago
It looks like IAR made a breaking change and projects that are created with their newer IDE cannot be opened in the older versions of IAR.  We are currently using IAR for ARM 7.50.1.10273 and was wondering what version was used for the SDK project (17.1.2)?  I've attached the error that is thrown when I try to open the project.

Tyler

DZX Support
Posted
3 years ago

Hi James,


The demo project was created using IAR v8.10. You are correct about the breaking change. It looks like IAR project files went to version '3' from '2' with their switch to 8.x versions.

I intended to keep demo projects compatible with older versions, but it looks like when I made changes to the SDK.ewp's, they were automatically upgraded. I will plan to roll them all back to version '2' for the next release. To help you right now, I've attached a rolled back project file for the one you referenced above.

Let me know if you have any issues with it.


Best Regards,

Tyler


James

Posted
3 years ago
Great, that's good news and the file worked well to get us up and running.  We appreciate the quick response.
Reply